macOS 安装 swoole 报错找不到 openssl/ssl.h 头文件

08-05 17:28 字数 581 阅读 1107

报错信息

/Users/luzhuang/Downloads/swoole-src-4.4.3/include/swoole.h:596:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
make: *** [php_swoole_cxx.lo] Error 1

报错很明显,找不到 openssl/ssl.h ,首先要确认电脑上有没有安装 openssl,如果没有安装的话可以用 brew 安装一下: brew install openssl , 但是我的电脑上是有的。

既然它找不到,那么就需要手动的指定 openssl 的目录:

./configure --enable-coroutine --enable-openssl  --enable-http2  --enable-async-redis --enable-sockets --enable-mysqlnd --with-openssl-dir=/usr/local/Cellar/openssl/1.0.2s --with-php-config=/Applications/MAMP/bin/php/php7.2.14/bin/php-config

如上,使用 --with-openssl-dir 参数指定 openssl 的参数后,就能正常安装了。

0人点赞>
关注 收藏 改进 举报
1 条评论
排序方式 时间 投票
Up骚年

php --ri swoole 查看是否安装成功

请登录后发表评论